start

Blog

adding
XDG_CURRENT_DESKTOP="KDE"
to /etc/environment
solves the problem for me
2020/04/25 16:54 · admin

Install Sublime Text 3 in Ubuntu 19.04 18.04

1.run command to add the keyring:

wget -qO - https://download.sublimetext.com/sublimehq-pub.gpg | sudo apt-key add -

2.Then run command to add the apt repository:

echo "deb https://download.sublimetext.com/ apt/stable/" | sudo tee /etc/apt/sources.list.d/sublime-text.list

3.Install sublime text 3

sudo apt update && sudo apt install sublime-text
2020/04/23 14:07 · admin

NVMe (Non-Volatile Memory Express) это спецификация для доступа к дискам через PCI Express, специально разработанная для энергонезависимой памяти. Подключение через PCIe Gen3 x4 не только обеспечивает скорость обмена данными (до четырех раз быстрее скорости доступа через интерфейс SATA), но и обеспечивает меньшие задержки, чем традиционные интерфейсы SATA. Высокий уровень параллелизма и низкое энергопотребление обеспечивает текущие и будущие потребности в хранении информации.

Особенности

Способ именования NVMe-SSD отличается от SATA-дисков. Первый NVMe-SSD имеет имя /dev/nvme0n1, а не /dev/sda. Здесь n после nvme0 означает пространство имён (namespace). Первый раздел на таких дисках имеет имя /dev/nvme0n1p1 вместо /dev/sda1.

Общая схема имеет вид:

/dev/nvme(номер контроллера)n(пространство имён)p(раздел)

vme-cli

Для управления NVMe-SSD под Linux можно использовать nvme-cli.

В Hetzner Rescue System эта утилита уже установлена. Показать список всех доступных NVMe-SSD

nvme list
Node             SN                   Model                                    Version  Namespace Usage                      Format           FW Rev
---------------- -------------------- ---------------------------------------- -------- --------- -------------------------- ---------------- --------
/dev/nvme0n1     S1XXNYAGAXXXXX       SAMSUNG MZVPV512HDGL-00000               1.1      1         102.40  GB / 512.11  GB    512   B +  0 B   BXW7300Q
/dev/nvme1n1     S1XXNYAGAYYYYY       SAMSUNG MZVPV512HDGL-00000               1.1      1         102.40  GB / 512.11  GB    512   B +  0 B   BXW7300Q

Показать серийный номер

nvme id-ctrl /dev/nvme0n1|egrep "sn|mn"
sn      : S1XXNYAGAXXXXX
mn      : SAMSUNG MZVPV512HDGL-00000

Показать информацию SMART

nvme smart-log /dev/nvme0n1
critical_warning                    : 0
temperature                         : 38 C
available_spare                     : 100%
available_spare_threshold           : 10%
percentage_used                     : 2%
data_units_read                     : 11,154,582
data_units_written                  : 26,350,216
host_read_commands                  : 654,517,238
host_write_commands                 : 825,794,277
controller_busy_time                : 814
power_cycles                        : 123
power_on_hours                      : 3,188
unsafe_shutdowns                    : 73
media_errors                        : 0
num_err_log_entries                 : 61
Warning Temperature Time            : 0
Critical Composite Temperature Time : 0

Показать журнал ошибок

nvme error-log /dev/nvme0n1
2020/04/15 02:00 · admin
/ip firewall layer7-protocol
add name=teamviewer regexp="^(post|get) /d(out|in).aspx\?.*client=dyngate"
add name=teamviewer1 regexp="^\\x17"
add name=ammyy regexp=^.*rl.ammyy.com.*
/ip firewall filter
add action=drop chain=forward layer7-protocol=teamviewer src-address-list=!yadmin
add action=drop chain=forward layer7-protocol=teamviewer1 src-address-list=!yadmin
add action=drop chain=forward layer7-protocol=ammyy src-address-list=!yadmin
add action=drop chain=forward dst-port=5938 protocol=tcp src-address-list=!yadmin
add action=drop chain=forward dst-port=5939 protocol=tcp src-address-list=!yadmin
add action=drop chain=forward dst-port=5938 protocol=udp src-address-list=!yadmin
add action=drop chain=forward dst-port=5939 protocol=udp src-address-list=!yadmin
add action=drop chain=forward content="teamviewer.com" src-address-list=!yadmin

Адреса кому можно пользоваться в списке yadmin. Заодно и Ammyy Admin блокировался.

2020/03/11 16:50 · admin
cat <<EOF | sudo tee /etc/apt/sources.list.d/mozilla.list
deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
EOF
 
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2667CA5C
sudo apt-get update
sudo apt-get install seamonkey-mozilla-build
2020/03/05 17:38 · admin

После обновления на домашнем ПК MS Windows до версии 1709 перестал подключаться к сетевой папке. Отваливается с ошибкой 0x80004005. Решение проблемы далее

Имеется домашний сервер на базе FreeBSD, на нем поднят SAMBA сервер, на котором расшарена папка. Безопасность в домашней сети нулевая, на SAMBA настроен гостевой доступ с полными правами к единственной сетевой папке. Все работало до обновления домашнего ПК с MS Windows 10 до версии 1709. После обновления этот комп перестал видеть шару. Остальные устройства видят шару как и раньше, без проблем. После обновления в MS Windows 10 «подкрутили гайки» с безопасностью и гостевой доступ стал недоступен. Ослабляем гайки и возвращаем доступ

Настройки можно произвести и через реестр

Default Registry Value:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
«AllowInsecureGuestAuth»=dword:0
Configured Registry Value:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters]
«AllowInsecureGuestAuth»=dword:1
2020/02/06 11:22 · admin
ssh 192.168.3.18
Unable to negotiate with 192.168.3.18 port 22: no matching cipher found. Their offer: aes128-cbc,3des-cbc,aes192-cbc,aes256-cbc
ssh -Q cipher
 
3des-cbc
aes128-cbc
aes192-cbc
aes256-cbc
rijndael-cbc@lysator.liu.se
aes128-ctr
aes192-ctr
aes256-ctr
aes128-gcm@openssh.com
aes256-gcm@openssh.com

Solved!

ssh -c aes256-cbc 192.168.3.18
2020/01/28 13:12 · admin

cat /root/ragent.sh

#!/bin/sh 
 
state=`service srv1cv83 status | /bin/grep 'Ragent: NOT RUNNING.'` 
notrun="Ragent: NOT RUNNING."
dt=`date '+%d/%m/%Y %H:%M:%S'`
lf=/var/log/ragent.log
 
if [[ "$state" == *$notrun* ]]; then 
service srv1cv83 restart
        echo "$dt — 1C ragent service failed to run! Will be restarted now." > $lf
else 
        echo "$dt — OK" > $lf
fi

crontab -l

*/5 * * * *     /bin/bash       /root/ragent.sh
2020/01/09 13:03 · admin

Спамеры могут рассылать нежелательные письма якобы от отправителей из вашего домена. Это называется спуфингом. Для его предотвращения используется технология Sender Policy Framework (SPF). Добавление записи SPF на сайте регистратора домена позволяет указать, какие почтовые серверы могут отправлять почту из вашего домена.

Если вы приобрели домен у партнера Google, например GoDaddy.com, eNom.com или DomainDiscount24.com, при регистрации аккаунта G Suite вам не нужно добавлять запись SPF. С подробной информацией можно ознакомиться в статье Настройки на сайте регистратора домена.

Как добавить запись TXT SPF на сайте регистратора домена

У вашего регистратора домена хранятся настройки, представляющие собой текстовые записи DNS. Они позволяют направлять интернет-трафик в ваш домен. Запись TXT SPF определяет почтовые серверы, которым разрешено отправлять электронную почту из домена. Если письмо отправлено с сервера, которого нет в записи, сервер получателя может классифицировать его как спам.

Примечание. В домене может использоваться только одна запись SPF, но она может включать несколько серверов.

Войдите в аккаунт своего домена на сайте регистратора (не в консоли администратора Google).

Перейдите на страницу, где можно обновить записи DNS. Эта страница может называться DNS management (Управление DNS), Name server management (Управление серверами доменных имен) или

Advanced settings (Расширенные настройки).

Найдите записи TXT и проверьте, есть ли среди них запись SPF.
Она начинается с "v=spf1".
Если в домене есть запись SPF, удалите ее.
Создайте запись TXT с указанными ниже значениями.
В поле Name/Host/Alias (Имя/хост/псевдоним) введите знак @ или оставьте его пустым.
Верное значение может быть указано в других записях DNS для вашего домена.
В поле Time to Live (TTL) (Время жизни) введите 3600 или оставьте значение по умолчанию.
В поле Value/Answer/Destination (Значение/ответ/назначение) введите v=spf1 include:_spf.google.com ~all.
Сохраните изменения.

Новая запись SPF начнет действовать в течение 48 часов.

Как добавить в запись SPF несколько серверов

В домене может быть только одна запись SPF, но в нее можно включить все свои почтовые серверы. Например, если вы настроили шлюз исходящей почты, запись SPF будет содержать адрес сервера Gmail и адрес SMTP-сервера этого шлюза.

Чтобы добавить почтовый сервер в существующую запись SPF, введите перед аргументом ~all IP-адрес этого сервера в формате ip4:адрес или ip6:адрес, как показано в этом примере:

v=spf1 ip4:172.16.254.1 include:_spf.google.com ~all

Чтобы добавить домены почтового сервера, используйте для каждого из них выражение include. Например:

v=spf1 include:serverdomain.com include:_spf.google.com ~all

Полная версия там https://support.google.com/a/answer/33786?hl=ru

2019/12/28 11:56 · admin

The best way to do this is to define a table and create a rule to block the hosts, in pf.conf:

table <badhosts> persist
block on fxp0 from <badhosts> to any

And then dynamically add/delete IP addresses from it:

$ pfctl -t badhosts -T add 1.2.3.4
$ pfctl -t badhosts -T delete 1.2.3.4

Other 'table' commands include flush (remove all), replace and show. See man pfctl for more.

If you want a more permanent list you can keep it in one (or more) files. In pf.conf:

table <badhosts> persist file «/etc/badguys1» file «/etc/badguys2» block on fxp0 from <badhosts> to any

You can also add hostnames instead of IP addresses. See the «Tables» section of man pf.conf and man pfctl.

Note: The examples above assume that the internet-facing interface is fxp0, please change according to your setup. Also, keep in mind that the rules in pf.conf are evaluated sequentially and for block or pass rules its the last matching rule that applies. With this ruleset

table <badhosts> persist
block on fxp0 from <badhosts> to any
pass inet tcp from 192.168.0.0/24 to any port 80

and after adding 1.2.3.4 and 192.168.0.10 to the badhosts table

$ pfctl -t badhosts -T add 1.2.3.4
$ pfctl -t badhosts -T add 192.168.0.10

all traffic from 1.2.3.4 and 192.168.0.10 will be blocked but the second host will be able to make connections to other machines' port 80 because the pass rule matches and overrides the block rule.

2019/12/23 11:52 · admin
  • start.txt
  • Последние изменения: 2019/10/24 23:52
  • admin